The NumLock on the touchpad is not responsive and not able to activate the number pad mode.


Please make sure:
1. The touchpad driver is properly installed. Please visit MSI global website to download and update the latest touchpad driver.
2. Please check “Enable Tap Zones” in touchpad properties.
3. After the laptop powers on, the button will be only working after the touchpad driver is loaded. So you may need to wait for a few seconds for its driver to be ready.
4. Don’t press Fn+F3 to disable the touchpad. This will also disable the NumLock.
5. Use tapping gesture to activate NumLock only. Do not press the NumLock for too long (more than 250 ms). If the press is too long, the NumLock may not be activated. Please see the following video for explanation:

https://www.msi.com/asset/global/pic...@faq_01654.mp4

6. The option "Disable internal device when external USB pointing device is attached" in the touchpad manager is not checked. Otherwise, it will automatically disable the touchpad and also the NumLock if you’ve plugged in any USB pointing device, such as a mouse.